Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 14 days ago. Nov 27, 2018 - 08:39 PST
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 14 days ago. Nov 27, 2018 - 08:34 PST