Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 10 days ago. Nov 07, 2018 - 21:23 PST
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 10 days ago. Nov 07, 2018 - 21:18 PST