Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 21 days ago. Nov 20, 2018 - 02:50 PST
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 21 days ago. Nov 20, 2018 - 02:40 PST