Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 23 days ago. Oct 25, 2018 - 13:31 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 23 days ago. Oct 25, 2018 - 13:31 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 23 days ago. Oct 25, 2018 - 13:16 PDT