Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 15 days ago. Sep 05, 2018 - 04:03 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 15 days ago. Sep 05, 2018 - 03:59 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 15 days ago. Sep 05, 2018 - 03:58 PDT