Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 31, 2018 - 15:11 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 17 days ago. Oct 31, 2018 - 15:01 PDT