Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 05, 2018 - 06:06 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 2 months ago. Aug 05, 2018 - 06:01 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 2 months ago. Aug 05, 2018 - 06:01 PDT