Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted about 2 months ago. Jul 30, 2018 - 01:13 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 2 months ago. Jul 30, 2018 - 01:12 PDT