Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 07, 2018 - 13:39 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 12 days ago. Sep 07, 2018 - 13:34 PDT