Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 21, 2018 - 00:08 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 3 months ago. Sep 21, 2018 - 00:04 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 3 months ago. Sep 21, 2018 - 00:03 PDT