Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 17 days ago. Jul 30, 2018 - 01:42 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 17 days ago. Jul 30, 2018 - 01:28 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 17 days ago. Jul 30, 2018 - 01:27 PDT