Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 16 days ago. Oct 03, 2018 - 07:43 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 16 days ago. Oct 03, 2018 - 07:39 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 16 days ago. Oct 03, 2018 - 07:38 PDT