Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 19 days ago. Sep 30, 2018 - 02:53 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 19 days ago. Sep 30, 2018 - 02:48 PDT