Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 9 days ago. Nov 08, 2018 - 05:23 PST
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 9 days ago. Nov 08, 2018 - 05:22 PST
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 9 days ago. Nov 08, 2018 - 05:22 PST