Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 25 days ago. Oct 23, 2018 - 00:23 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 25 days ago. Oct 23, 2018 - 00:18 PDT