Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 15 days ago. Nov 02, 2018 - 21:02 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 15 days ago. Nov 02, 2018 - 20:41 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 15 days ago. Nov 02, 2018 - 20:38 PDT