Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 17, 2018 - 04:36 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 1 month ago. Oct 17, 2018 - 04:21 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 1 month ago. Oct 17, 2018 - 04:21 PDT