Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 20 days ago. Aug 31, 2018 - 05:30 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 20 days ago. Aug 31, 2018 - 05:25 PDT