Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 06, 2018 - 09:16 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 9 days ago. Aug 06, 2018 - 09:11 PDT