Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 10, 2018 - 02:44 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 2 months ago. Sep 10, 2018 - 02:39 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 2 months ago. Sep 10, 2018 - 02:39 PDT