Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 17 days ago. Jul 29, 2018 - 04:55 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 17 days ago. Jul 29, 2018 - 04:52 PDT