Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 29 days ago. Nov 12, 2018 - 11:55 PST
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 29 days ago. Nov 12, 2018 - 11:51 PST
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 29 days ago. Nov 12, 2018 - 11:36 PST