Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 22 days ago. Nov 19, 2018 - 12:25 PST
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 22 days ago. Nov 19, 2018 - 12:19 PST
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 22 days ago. Nov 19, 2018 - 12:04 PST