Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 04, 2018 - 12:06 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 1 month ago. Oct 04, 2018 - 11:59 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted about 1 month ago. Oct 04, 2018 - 11:45 PDT