Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 23, 2018 - 11:23 PDT
Update
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 3 months ago. Sep 23, 2018 - 11:19 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 3 months ago. Sep 23, 2018 - 11:18 PDT