Video Errors
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 18 days ago. Jul 29, 2018 - 03:12 PDT
Investigating
We are experiencing an increase in video playback errors and are currently looking into the issue.
Posted 18 days ago. Jul 29, 2018 - 03:07 PDT