Increased Application Latency
Incident Report for Crunchyroll
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 01, 2018 - 05:34 PDT
Investigating
We are experiencing increased load on our systems which is resulting in degraded application performance. We are working to return site functionality to normal.
Posted 4 months ago. Aug 01, 2018 - 05:33 PDT